SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000814SiT!incidentspublic2009-07-27 12:242009-08-16 14:39
Reporternicdev 
Assigned Toivan 
PriorityhighSeverityblockReproducibilityunable to reproduce
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.45 
Target Version3.50Fixed in Version3.50 
Summary0000814: Auto assign of incidents, assigns to people with no skills, and who are not accepting:on holiday
DescriptionWhen we create an incident from the holding queue, and auto assign is on, the incident is created, and then when the redirect occurs to "auto assign" the assignment sometimes go to the manager (who has no skills listed) or to an engineer who is on holiday (and not accepting) or even to engineers who's accounts have been disabled.

I have checked that at this time there are engineers available with the required skill but it does not assign it to them. This is causing some big issues, where new cases are not noticed...

In our setup in fact we have only for level 3 engineers (2 for software and 2 for hardware) and we thought it could even work to "auto assign" one for one if both engineers for that order is in or just to one if the other is on holidays?

this may be a feature request, but for now the incorrect assignment is a big issue.
TagsNo tags attached.
Attached Files

- Relationships
parent of 0000815closedkieran Possible for auto-assign to assign to a user who is marked "not accepting". 
parent of 0000816closedivan Auto-assign incidents might be assigned to nobody 

-  Notes
User avatar (0001441)
ivan (administrator)
2009-07-27 13:14

Hi Nico, Thanks for the bug report.

This is a blocking bug if incidents are assigned to user accounts that have been disabled. I'll try reproduce this.

The criteria for auto-assign is listed on the wiki page here http://sitracker.org/wiki/Auto_assign [^]
User avatar (0001444)
ivan (administrator)
2009-07-27 14:24

As I understand it there are 3 issues reported here:

a) Auto-assign to users with no appropriate skills
b) Auto-assign to users who are not accepting (e.g. on holiday)
c) Auto-assign to users who's accounts are disabled

In turn:

a) This is by design, please refer to http://sitracker.org/wiki/Auto_assign [^] - users with skills are preferred, but users without skills are not excluded.

b) It does appear to be possible in some cases for auto-assign to assign to a user who is marked "not accepting".

c) I can't see anywhere that would allow an incident to go to an account that is disabled, I'm not convinced that is possible. At least not with the current code.

d) Additionally while looking into this I discovered an issue that might arise if auto-assign could not find a suitable user to assign to, (e.g. nobody was accepting) the incident might be assigned to nobody (shown as SiT!).

I'll log the two related bugs (b&d), but I'll need more information to be able to get to the issue of auto-assigning to disabled accounts.
User avatar (0001447)
nicdev (developer)
2009-07-28 13:35

Hi Ivan,

I ran some tests and i think i found the issue but i am not sure yet why ...

I found that i had a few incidents where the "software" was "unknown" and it seems it were these ones, that were assigned to disabled accounts or users out of office and with no skill....

I am not sure why the "software" was not set on these incidents, but it seems to work well as long as there is a "software"...

to reproduce it i made a quick script to run the function "suggest_reassign_userid"(), and i used an incident where the software was not set (or set to 0) and it fails...
User avatar (0001448)
ivan (administrator)
2009-07-28 14:23

Thanks, can you attach your script here. I'll take a look when I have time. Busy this afternoon, but should find time tonight hopefully.
User avatar (0001450)
kieran (administrator)
2009-07-28 14:48
edited on: 2009-07-28 14:50

I did the following:

* Created two users, one disabled
* Created four incidents, one with no product, software or maintenance set
* Ran:

for ($i = 0; $i < 10000; $i++) {
    $user = suggest_reassign_userid(1);
    if ($user != 1) echo $user."\n";
}

I couldn't get it to assign to anyone but user 1. Could you download the latest version of the code (http://sitracker.svn.sourceforge.net/viewvc/sitracker/trunk/lib/incident.inc.php?revision=5444&view=markup [^]) and diff it with your version, the code starts at line 225.

User avatar (0001452)
nicdev (developer)
2009-07-29 10:35

Hi Kieran/Ivan,

I have put the latest revision of incident.inc.php into our test server and all is ok. No more reassignment to anyone that is not in the office, or not accepting...

i must admit that even though it turned out to be a bug it only came to light because i made a mistake in our plugin "auto_create" that creates case directly out of the inbound script based on keywords (i missed an elseif and i had some cases with no software set). but in the end it worked out ok, as it was a bug, and now it is fixed.

Thanks for the rapid response, and the quick fix.

i think you can close this one. i tested with about 30 mails (with our plugin and without it) and the results are 100% correct.

Cheers
User avatar (0001453)
ivan (administrator)
2009-07-29 11:42

Thanks Nicdev
User avatar (0001689)
ivan (administrator)
2009-08-16 14:39

Released in 3.50rc1

- Issue History
Date Modified Username Field Change
2009-07-27 12:24 nicdev New Issue
2009-07-27 13:14 ivan Note Added: 0001441
2009-07-27 13:14 ivan Severity major => block
2009-07-27 14:24 ivan Note Added: 0001444
2009-07-27 14:24 ivan Reproducibility sometimes => unable to reproduce
2009-07-27 14:24 ivan Status new => acknowledged
2009-07-27 14:26 ivan Relationship added parent of 0000815
2009-07-27 14:27 ivan Relationship added parent of 0000816
2009-07-28 13:35 nicdev Note Added: 0001447
2009-07-28 14:23 ivan Note Added: 0001448
2009-07-28 14:48 kieran Note Added: 0001450
2009-07-28 14:50 kieran Note Edited: 0001450
2009-07-28 19:43 ivan Status acknowledged => feedback
2009-07-29 10:35 nicdev Note Added: 0001452
2009-07-29 11:42 ivan Note Added: 0001453
2009-07-29 11:42 ivan Assigned To => ivan
2009-07-29 11:42 ivan Status feedback => resolved
2009-07-29 11:42 ivan Resolution open => fixed
2009-07-29 11:42 ivan Fixed in Version => Current SVN
2009-07-29 11:42 ivan Target Version => 3.50
2009-08-16 13:15 ivan Fixed in Version Current SVN => 3.50
2009-08-16 14:39 ivan Note Added: 0001689
2009-08-16 14:39 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker