SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000829SiT!i18npublic2009-07-29 17:572010-03-27 12:31
Reporterivan 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.60 LTSFixed in Version3.60 LTS 
Summary0000829: SYSLANG assumes system language is 100% complete
DescriptionIf a syslang i18n key is missing, blank (or empty string) is used instead. It would be preferable to use English in case the syslang isn't 100% complete.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0002625)
ivan (administrator)
2010-03-07 11:22

I'm not sure we can do anything about this other than warn if a default language is chosen that isn't 100% complete.
User avatar (0002702)
kieran (administrator)
2010-03-14 19:59

As mentioned on IRC, we could load english into $SYSLANG and array_merge() with the chosen system language.
User avatar (0002744)
ivan (administrator)
2010-03-20 14:12

Fixed in 3.x svn r6290 We now load the en-GB file first before loading the chosen system language. Seems fast enough.
User avatar (0002846)
ivan (administrator)
2010-03-23 21:43

Fixed in git 6bc333f
User avatar (0002875)
ivan (administrator)
2010-03-27 10:18

The fix to this isn't completely correct because syslang text in inbound emails is missing.
User avatar (0002876)
ivan (administrator)
2010-03-27 10:46

Fix to the fix fixed in svn 3.x r6365 and git e25ac33

- Issue History
Date Modified Username Field Change
2009-07-29 17:57 ivan New Issue
2010-02-20 20:00 paulh Status new => confirmed
2010-02-20 20:00 paulh Target Version => 3.60 LTS
2010-03-07 11:22 ivan Note Added: 0002625
2010-03-14 19:59 kieran Note Added: 0002702
2010-03-14 20:04 ivan Status confirmed => assigned
2010-03-14 20:04 ivan Assigned To => ivan
2010-03-20 14:12 ivan Note Added: 0002744
2010-03-20 14:12 ivan Status assigned => resolved
2010-03-20 14:12 ivan Fixed in Version => Current SVN
2010-03-20 14:12 ivan Resolution open => fixed
2010-03-23 21:43 ivan Note Added: 0002846
2010-03-27 10:18 ivan Note Added: 0002875
2010-03-27 10:18 ivan Status resolved => assigned
2010-03-27 10:18 ivan Resolution fixed => reopened
2010-03-27 10:46 ivan Note Added: 0002876
2010-03-27 10:46 ivan Status assigned => resolved
2010-03-27 10:46 ivan Resolution reopened => fixed
2010-03-27 11:16 ivan Fixed in Version Current SVN => 3.60 LTS
2010-03-27 12:31 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker