SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000910SiT!sites & contactspublic2009-08-27 08:092009-10-15 21:55
Reportersancho78rus 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityunable to reproduce
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.50Fixed in Version3.50 
Summary0000910: Cannot find contact by first letter
Descriptionwhen client begins with russian ?, it does not appear when serching in letter A. but if change russian A on engish A - its ok.
Other russian letter, that we tryed were ok.
version 3.50
TagsNo tags attached.
Attached Files

- Relationships
related to 0000798closedivan cannot find any contact by clicking on its first letter (in russian) 
related to 0000912resolvedivan search_string=A on url for browse pages assumes english language 
related to 0000937closed Branch3 SVN - Clicking on the DK Letter Å shows results from A 

-  Notes
(0001838)
sancho78rus (reporter)
2009-08-27 09:11

one more bug...
when pressing on letter it displays not clients, that begings with this letter, but clients that contains this letter.
User avatar (0001840)
ivan (administrator)
2009-08-27 10:37

Thanks for the bug report, I had thought that this was fixed. I'll do some more testing to make sure.
User avatar (0001849)
ivan (administrator)
2009-08-27 13:27

I can't reproduce this, I suspect this is happening because your database is not set to use UTF-8. It works fine in v3.50rc1.
User avatar (0001866)
ivan (administrator)
2009-08-27 15:14

Reopening this as I've managed to reproduce it with your database.
User avatar (0001867)
ivan (administrator)
2009-08-27 15:15
edited on: 2009-08-27 15:16

It seems that strlen('?') returns 2 when using Russian language instead of the expected 1. (Mantis has garbled the text, but the ? there is the Russian 'A' character)

(0001868)
sancho78rus (reporter)
2009-08-27 16:27

and dont forget that other letters also dont work properly (serarching not by first letter)
User avatar (0001870)
ivan (administrator)
2009-08-27 17:43

They do now :-) The fix will be in 3.50 final.
User avatar (0001951)
ivan (administrator)
2009-09-12 12:59

http://github.com/sitracker/sitracker/commit/dad3622a3b1073bb688053a7e38b9b2576b50af1 [^]
User avatar (0001952)
ivan (administrator)
2009-09-12 13:23

Fixed in 3.50rc2

- Issue History
Date Modified Username Field Change
2009-08-27 08:09 sancho78rus New Issue
2009-08-27 09:11 sancho78rus Note Added: 0001838
2009-08-27 10:04 ivan Relationship added related to 0000798
2009-08-27 10:37 ivan Note Added: 0001840
2009-08-27 10:37 ivan Status new => acknowledged
2009-08-27 11:52 ivan Severity major => minor
2009-08-27 13:27 ivan Note Added: 0001849
2009-08-27 13:27 ivan Reproducibility always => unable to reproduce
2009-08-27 13:27 ivan Status acknowledged => closed
2009-08-27 13:27 ivan Resolution open => unable to reproduce
2009-08-27 15:14 ivan Note Added: 0001866
2009-08-27 15:14 ivan Status closed => confirmed
2009-08-27 15:15 ivan Note Added: 0001867
2009-08-27 15:16 ivan Note Edited: 0001867 View Revisions
2009-08-27 15:26 ivan Relationship added related to 0000912
2009-08-27 16:27 sancho78rus Note Added: 0001868
2009-08-27 17:43 ivan Note Added: 0001870
2009-08-27 17:43 ivan Status confirmed => assigned
2009-08-27 17:43 ivan Assigned To => ivan
2009-09-12 12:59 ivan Note Added: 0001951
2009-09-12 13:22 ivan Status assigned => resolved
2009-09-12 13:22 ivan Fixed in Version => 3.50
2009-09-12 13:23 ivan Note Added: 0001952
2009-09-12 13:23 ivan Resolution unable to reproduce => fixed
2009-09-12 13:31 ivan Target Version => 3.50
2009-09-12 14:38 ivan Relationship added related to 0000937
2009-10-15 21:55 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker