SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000937SiT!sites & contactspublic2009-09-12 14:352013-01-05 15:59
ReporterTomse 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionnot fixable 
PlatformOSOS Version
Product VersionCurrent SVN 
Target Version3.90beta1Fixed in Version 
Summary0000937: Branch3 SVN - Clicking on the DK Letter Å shows results from A
DescriptionIn Contracts, Contacts, and Sites

clicking on Å gives results of A
TagsNo tags attached.
Attached Files

- Relationships
related to 0000910closedivan Cannot find contact by first letter 
parent of 0001146confirmed Setup should ask which collation to use 
related to 0000936closed Branch3 SVN - No footer after search 
Not all the children of this issue are yet resolved or closed.

-  Notes
User avatar (0001964)
ivan (administrator)
2009-09-13 11:22

ok I found the answer to this but it complicates things a bit. mysql treats 'A' and 'Å' as equivelant with utf-8 general collation, it will also sort them incorrectly. Å will come before Z.

The correct way to solve this is to use 'utf8_danish_ci' collation. I'm not immediately sure of the implications of changing this, and obviously this means we need to do something during setup so that we use the correct collation.
User avatar (0001977)
Tomse (developer)
2009-09-17 15:31

Thinking internationally here..

this might complicate things if, say
2 support departments
1 in DK
and another 1 in russia

but that also opens up pandoras box..
User avatar (0001988)
ivan (administrator)
2009-09-17 17:13
edited on: 2009-09-17 17:14

Unfortunately due to it's complexity this one is not gonna be resolved for 3.50. I hope this doesn't cause too many problems for people.

@tomse: yeah I thought of that too, it's going to need some thinking about this one

User avatar (0002680)
ivan (administrator)
2010-03-14 12:41

Confirmed that changing the collation to 'utf8_danish_ci' fixes this issue (for Danish). There's nothing we can really do to fix this for 3.x since we're feature frozen and it would mean adding more code to support multiple collations.

It does complicate things when SiT! is being used in an international situation. I'll add some documentation (somewhere?) about using other collations and maybe we can look at making the setup let the user choose the collation to use in 4.x
User avatar (0004629)
ivan (administrator)
2013-01-05 15:59

This will be resolved by 0001146

- Issue History
Date Modified Username Field Change
2009-09-12 14:35 Tomse New Issue
2009-09-12 14:38 ivan Relationship added related to 0000910
2009-09-12 15:39 ivan Assigned To => kieran
2009-09-12 15:39 ivan Status new => assigned
2009-09-12 15:39 ivan Target Version => 3.50
2009-09-12 16:14 ivan Assigned To kieran => ivan
2009-09-12 19:32 ivan Relationship added related to 0000936
2009-09-13 11:22 ivan Note Added: 0001964
2009-09-17 15:31 Tomse Note Added: 0001977
2009-09-17 17:13 ivan Note Added: 0001988
2009-09-17 17:13 ivan Target Version 3.50 => 3.60
2009-09-17 17:14 ivan Note Edited: 0001988 View Revisions
2010-03-14 12:41 ivan Note Added: 0002680
2010-03-14 12:41 ivan Target Version 3.60 LTS => 4.0
2010-03-14 12:49 ivan Relationship added parent of 0001146
2010-04-06 20:03 paulh Severity trivial => minor
2011-02-14 13:21 ivan Target Version 4.0 => 3.90beta1
2013-01-05 15:59 ivan Note Added: 0004629
2013-01-05 15:59 ivan Status assigned => resolved
2013-01-05 15:59 ivan Resolution open => not fixable
2013-01-05 15:59 ivan Status resolved => closed
2013-01-05 15:59 ivan Assigned To ivan =>


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker