SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000948SiT!profilespublic2009-09-19 10:342011-06-15 21:50
Reporterivan 
Assigned Topaulh 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product VersionCurrent GIT 
Target Version3.90beta1Fixed in VersionCurrent GIT 
Summary0000948: "User.retrieveDetails() not yet implemented" on user profile page
DescriptionApplication Notice [1024]
User.retrieveDetails() not yet implemented in /home/ivan/src/git-sit/sitracker/lib/user.class.php @ line 65
Backtrace:
/home/ivan/src/git-sit/sitracker/lib/user.class.php @ line 65 trigger_error()
/home/ivan/src/git-sit/sitracker/lib/user.class.php @ line 59 retrieveDetails()
/home/ivan/src/git-sit/sitracker/user_profile_edit.php @ line 51 User()
Steps To ReproduceView the user profile page, notice appears at the top of the page
TagsNo tags attached.
Attached Filespng file icon sit390.usr.retrievedetails.png [^] (36,537 bytes) 2011-06-03 22:37

- Relationships
related to 0001597closedTomse My profile page doesn't save settings 

-  Notes
User avatar (0001997)
paulh (administrator)
2009-09-19 13:20

Ivan,

This code should not be present in the 3.x branch and doesn't appear to be present in mine. Though I can reproduce this with the 4 branch, the trigger_error can be removed as the retrieval has been implemented
User avatar (0001998)
ivan (administrator)
2009-09-19 13:39

I wonder if my code is a bit messed up then. I'll have another look.
User avatar (0001999)
ivan (administrator)
2009-09-19 14:57

sitracker: Ivan Lucas sitracker3 * r1308bc2 / (lib/functions.inc.php lib/user.class.php): Remove "User.retrieveDetails() not yet implemented" notice since it is implemented now. Fixes Mantis bug 948 - http://bit.ly/wyF4p [^]
User avatar (0003625)
ivan (administrator)
2011-02-20 21:09

I'm seeing this message again with the latest Git on the Edit user profile page. Git 7b589e91
User avatar (0004018)
Tomse (developer)
2011-06-15 21:50

This was probably fixed when PH fixed the email templates for the trigger system

- Issue History
Date Modified Username Field Change
2009-09-19 10:34 ivan New Issue
2009-09-19 13:20 paulh Note Added: 0001997
2009-09-19 13:39 ivan Note Added: 0001998
2009-09-19 14:57 ivan Note Added: 0001999
2009-09-19 14:57 ivan Status new => resolved
2009-09-19 14:57 ivan Fixed in Version => Current SVN
2009-09-19 14:57 ivan Resolution open => fixed
2009-09-19 14:57 ivan Assigned To => ivan
2009-10-15 20:38 ivan Fixed in Version Current SVN => 3.50
2009-10-15 21:55 ivan Status resolved => closed
2011-02-20 21:09 ivan Assigned To ivan =>
2011-02-20 21:09 ivan Note Added: 0003625
2011-02-20 21:09 ivan Status closed => feedback
2011-02-20 21:09 ivan Resolution fixed => reopened
2011-02-20 21:09 ivan Product Version 3.50 => Current GIT
2011-02-20 21:09 ivan Fixed in Version 3.50 =>
2011-02-20 21:09 ivan Target Version 3.50 => 3.90beta1
2011-06-03 22:37 Tomse File Added: sit390.usr.retrievedetails.png
2011-06-03 22:45 ivan Status feedback => confirmed
2011-06-15 13:25 ivan Relationship added related to 0001597
2011-06-15 21:50 Tomse Note Added: 0004018
2011-06-15 21:50 Tomse Status confirmed => resolved
2011-06-15 21:50 Tomse Fixed in Version => Current GIT
2011-06-15 21:50 Tomse Resolution reopened => fixed
2011-06-15 21:50 Tomse Assigned To => paulh


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker