SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000971SiT!inbound emailpublic2009-10-02 10:282009-10-15 21:55
Reporternicdev 
Assigned Tonicdev 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.45 
Target VersionFixed in Version3.50 
Summary0000971: Make it possible to change the "reason text" in the holding queue from a plugin,
DescriptionWhile developing our auto create plugin we found it necessary to be able to change the "reason text" depending on the script we created.

We need a way to make this a variable so as not to have to change the actual inbound script each time.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0002068)
nicdev (developer)
2009-10-07 12:39

As a temporary measure i have changed the the inboundemail script as follows:
At line 395 AND 471 added:

//new call
if (!$GLOBALS['plugin_reason']) $reason = $SYSLANG['strPossibleNewIncident'];
else $reason = $GLOBALS['plugin_reason'];

And then changed lines 425 and 475:
            
$sql .= "'".mysql_real_escape_string($reason)."', '{$contactid}' )";

All that remains now is to set the global inside the code of yourplugin like this:
$GLOBALS['plugin_reason'] = "Because i want a different reason"

Let me know what you think of that as a permanent solution.
User avatar (0002069)
ivan (administrator)
2009-10-07 13:51

We can do this as a solution for now and improve upon it later, feel free to commit this. thanks.
User avatar (0002072)
nicdev (developer)
2009-10-07 15:07

Fixed for now by a solution to be improved on later.

In SVN Branches/3.x Revision 5930

- Issue History
Date Modified Username Field Change
2009-10-02 10:28 nicdev New Issue
2009-10-02 13:41 ivan Status new => confirmed
2009-10-07 12:39 nicdev Note Added: 0002068
2009-10-07 13:51 ivan Note Added: 0002069
2009-10-07 15:05 nicdev Status confirmed => assigned
2009-10-07 15:05 nicdev Assigned To => nicdev
2009-10-07 15:07 nicdev Note Added: 0002072
2009-10-07 15:07 nicdev Status assigned => resolved
2009-10-07 15:07 nicdev Fixed in Version => 3.50
2009-10-07 15:07 nicdev Resolution open => fixed
2009-10-15 21:55 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker