SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000974SiT!holidayspublic2009-10-07 15:032010-03-27 12:31
Reporterpaulh 
Assigned Toivan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.60 LTSFixed in Version3.60 LTS 
Summary0000974: Holidays taken on holidays.php counts denied holidays
DescriptionThis page count appears to include holidays which have been denied
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
User avatar (0002073)
paulh (administrator)
2009-10-07 20:53

reproduced this with the latest 3.5 code

Steps ro repro

UserA request holiday
UserB declines


User A sees number of days taken incremented by one
User avatar (0002418)
ivan (administrator)
2010-02-20 19:39

Can't reproduce this with v3.99 (4.x branch)
User avatar (0002420)
ivan (administrator)
2010-02-20 19:43
edited on: 2010-02-20 19:44

function user_count_holidays($userid, $type, $date=0,
                             $approved = array(HOL_APPROVAL_NONE, HOL_APPROVAL_GRANTED, HOL_APPROVAL_DENIED))



Such a strange default, we should change this

User avatar (0002681)
ivan (administrator)
2010-03-14 13:19

Again I can't reproduce this with svn 3.x branch r6239

I did do some work around this area a few months back (could have been longer) so maybe it got fixed?
User avatar (0002723)
Tomse (developer)
2010-03-17 18:32

I've tried reproducing this aswell in 3.x
not able to do so.

I guess it's fixed?
User avatar (0002724)
ivan (administrator)
2010-03-17 18:41

Marking fixed since we can't reproduce it, but not sure which commit actually did the fixing. If this resurfaces please reopen. thanks.

- Issue History
Date Modified Username Field Change
2009-10-07 15:03 paulh New Issue
2009-10-07 20:53 paulh Note Added: 0002073
2010-02-20 19:39 ivan Note Added: 0002418
2010-02-20 19:43 ivan Status new => assigned
2010-02-20 19:43 ivan Assigned To => ivan
2010-02-20 19:43 ivan Note Added: 0002420
2010-02-20 19:44 ivan Target Version => 3.60 LTS
2010-02-20 19:44 ivan Note Edited: 0002420 View Revisions
2010-03-14 13:19 ivan Note Added: 0002681
2010-03-14 13:19 ivan Status assigned => feedback
2010-03-17 18:32 Tomse Note Added: 0002723
2010-03-17 18:41 ivan Note Added: 0002724
2010-03-17 18:41 ivan Status feedback => resolved
2010-03-17 18:41 ivan Fixed in Version => 3.60 LTS
2010-03-17 18:41 ivan Resolution open => fixed
2010-03-27 12:31 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker