SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000976SiT!reportspublic2009-10-08 20:212010-03-27 12:30
ReporterCartmanVS 
Assigned Topaulh 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.45 
Target Version3.60 LTSFixed in Version3.60 LTS 
Summary0000976: Save as CSV request in Incident Duration report causes error
DescriptionIn the "Average Incident Duration" report if you select the SAVE AS CSV link underneath the statistics, the following error is generated as the actual file:

<p class='warning'>Warning [2]
Invalid argument supplied for foreach() in D:\Websites\yourbackdoor.co.uk\httpdocs\lib\functions.inc.php @ line 7778 sit_error_handler() create_report()



Excel correctly opens with the downloaded file, but the above error is the content of the first Cell.
TagsNo tags attached.
Attached Filespng file icon report_screengrab.png [^] (64,500 bytes) 2009-10-08 20:41

- Relationships
duplicate of 0001015closedpaulh The csv export function does not work in the report "average incident duration" 

-  Notes
User avatar (0002074)
ivan (administrator)
2009-10-08 20:34

Is that with a completely blank database or is that with some incidents?

I haven't looked yet but that's the kind of error that happens when trying to loop over an empty dataset.
(0002076)
CartmanVS (reporter)
2009-10-08 20:42

Definately a populated data set, because the summary shows the proper Average Duration (which incidentally appears to now be fixed in this release - used to summarise the wrong month). I've attached a screengrab of the data. Nothing confidential on the image to worry about, but feel free to delete if you are concerned about the content.

Kevin
User avatar (0002079)
paulh (administrator)
2009-10-08 21:14

unable to reproduce this exact error on my system here though do get a problem I think is related/the cause of this, when I try and download a CSV report I get an empty file.
User avatar (0002797)
paulh (administrator)
2010-03-21 14:32

fixed in 3.6 (See related bug 1015), this will be released end of this mornth

- Issue History
Date Modified Username Field Change
2009-10-08 20:21 CartmanVS New Issue
2009-10-08 20:34 ivan Note Added: 0002074
2009-10-08 20:34 ivan Status new => feedback
2009-10-08 20:41 CartmanVS File Added: report_screengrab.png
2009-10-08 20:42 CartmanVS Note Added: 0002076
2009-10-08 21:14 paulh Note Added: 0002079
2009-10-23 14:25 ivan Status feedback => acknowledged
2010-03-21 14:30 paulh Relationship added duplicate of 0001015
2010-03-21 14:32 paulh Note Added: 0002797
2010-03-21 14:32 paulh Status acknowledged => resolved
2010-03-21 14:32 paulh Resolution open => fixed
2010-03-21 14:32 paulh Fixed in Version => Current SVN
2010-03-27 11:10 ivan Assigned To => paulh
2010-03-27 11:10 ivan Target Version => 3.60 LTS
2010-03-27 11:16 ivan Fixed in Version Current SVN => 3.60 LTS
2010-03-27 12:30 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker