SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000985SiT!inbound emailpublic2009-10-15 21:482010-03-27 12:30
Reporterivan 
Assigned Topaulh 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.60 LTSFixed in Version3.60 LTS 
Summary0000985: Error message: Warning imap_open() expects parameter 4 to be long
DescriptionThis message appears when you have PHP version 5.2 or later installed. The imap() function has changed since PHP version 5.2 (see http://php2.mirrors-r-us.net/UPDATE_5_2.txt [^]), and the SiT code is not adapted for it yet.

For the moment the workaround is to downgrade to an earlier version of PHP.

The original message in the php error log is:
Warning imap_open() expects parameter 4 to be long


see http://sitracker.org/forum/viewtopic.php?f=4&t=1416918 [^]
TagsNo tags attached.
Attached Files

- Relationships
child of 0001083closedivan Support for php5.2 and up - Issues found are mostly IMAP 

-  Notes
User avatar (0002407)
paulh (administrator)
2010-02-20 17:42

This isn't a 5.2 issue, 5.2 added a 5th parameter (n_retries) the error her is we're passing CL_EXPUNGE' as a string as parameter 4 it should be a int so we should pass CL_EXPUNGE
User avatar (0002477)
paulh (administrator)
2010-02-25 19:51

Interestingly I don't seem to get this error running php 5.2.12-2 (debian) upgrading to 5.3 to see if I can repro (this is with the code base as it stands). I did get alot of notice and warnings though not this one (and mostly due to my LDAP server being down)
(0002507)
sancho78rus (reporter)
2010-02-26 15:53

cannot recieve mail using php 5.3
is it sit bug?
(0002508)
sancho78rus (reporter)
2010-02-26 19:33

cannot make it work with php 5.3
but it works fine with php 5.2.6
User avatar (0002514)
paulh (administrator)
2010-02-27 11:18

Can repo
2010-02-27T11:17:27+00:00 auto.php ERROR: Warning imap_open() expects parameter 4 to be long, string given in /home/paulh/sit/lib/fetchSitMail.class.php at line 66
with PHP5.3 will look into
User avatar (0002515)
paulh (administrator)
2010-02-27 11:24

http://gitorious.org/sit/sit/commit/41f10a2ee96801e5a209bf24fff7bb4303c98e85 [^] and r6162 resolves this

'CL_EXPUNGE' should have been an int so changed to CL_EXPUNGE

- Issue History
Date Modified Username Field Change
2009-10-15 21:48 ivan New Issue
2009-10-23 14:24 ivan Status new => acknowledged
2010-02-20 10:31 Tomse Relationship added child of 0001083
2010-02-20 11:24 ivan Status acknowledged => confirmed
2010-02-20 17:42 paulh Note Added: 0002407
2010-02-25 19:51 paulh Note Added: 0002477
2010-02-25 19:51 paulh Target Version => 3.60 LTS
2010-02-26 15:53 sancho78rus Note Added: 0002507
2010-02-26 19:33 sancho78rus Note Added: 0002508
2010-02-27 11:18 paulh Note Added: 0002514
2010-02-27 11:18 paulh Assigned To => paulh
2010-02-27 11:18 paulh Status confirmed => assigned
2010-02-27 11:24 paulh Note Added: 0002515
2010-02-27 11:24 paulh Status assigned => resolved
2010-02-27 11:24 paulh Resolution open => fixed
2010-02-27 11:24 paulh Fixed in Version => Current SVN
2010-03-27 11:16 ivan Fixed in Version Current SVN => 3.60 LTS
2010-03-27 12:30 ivan Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker