SiT! Bugs - SiT!
View Issue Details
0001062SiT!reportspublic2010-02-10 20:412010-03-27 12:30
paulh 
paulh 
normalminoralways
closedfixed 
 
3.60 LTS3.60 LTS 
0001062: report_incidents_by_skill.php pie chart wrong
If you run this report the pie chart always shows 100% for others even though its 0% reproduced with latest svn (3.x)
No tags attached.
has duplicate 0000738closed  chart is covered up with one color 
Issue History
2010-02-10 20:41paulhNew Issue
2010-02-10 20:55paulhNote Added: 0002345
2010-02-11 10:12ivanNote Added: 0002346
2010-02-11 10:12ivanStatusnew => confirmed
2010-02-11 21:48paulhNote Added: 0002352
2010-02-13 12:20paulhStatusconfirmed => assigned
2010-02-13 12:20paulhAssigned To => paulh
2010-02-14 13:10paulhNote Added: 0002376
2010-02-14 13:10paulhStatusassigned => resolved
2010-02-14 13:10paulhResolutionopen => fixed
2010-02-14 13:10paulhFixed in Version => Current SVN
2010-02-14 13:10paulhTarget Version => 3.60
2010-03-25 21:41paulhRelationship addedhas duplicate 0000738
2010-03-27 11:16ivanFixed in VersionCurrent SVN => 3.60 LTS
2010-03-27 12:30ivanStatusresolved => closed

Notes
(0002345)
paulh   
2010-02-10 20:55   
Appears to be draw_chart_image in functions.inc.php which is drawing the chart incorrectly
(0002346)
ivan   
2010-02-11 10:12   
Originally reported in this forum thread http://sitracker.org/forum/viewtopic.php?f=4&t=1416980 [^]
(0002352)
paulh   
2010-02-11 21:48   
Identified this happens when you have an item on the pie which has a percentage of 0% so potentially effects anywhere in SiT! where pies are used
(0002376)
paulh   
2010-02-14 13:10   
r6082 resolves in 3.x and trunk