SiT! Bugs - SiT!
View Issue Details
0000652SiT!inbound emailpublic2009-04-20 10:322009-08-16 14:38
nicdev 
ivan 
normalmajoralways
closedfixed 
3.45 
3.503.50 
0000652: New mail from "unrecognised" contact, cannot be linked to an existing case
When we have an email from a "known" contact, top part of the holding queue, then we assign such emails to an existing incident, but when it is in the "unrecognised" part of the list, the assignment fails saying that the incident cannot be linked.
No tags attached.
Issue History
2009-04-20 10:32nicdevNew Issue
2009-04-20 11:12ivanNote Added: 0000939
2009-04-20 11:12ivanStatusnew => feedback
2009-04-20 13:10nicdevNote Added: 0000947
2009-04-20 13:51nicdevNote Added: 0000948
2009-04-20 13:52nicdevAssigned To => ivan
2009-04-21 22:00ivanNote Added: 0000954
2009-04-21 22:00ivanStatusfeedback => resolved
2009-04-21 22:00ivanResolutionopen => fixed
2009-04-21 22:00ivanFixed in Version => Current SVN
2009-04-21 22:00ivanTarget Version => 3.50
2009-08-16 13:17ivanFixed in VersionCurrent SVN => 3.50
2009-08-16 14:38ivanNote Added: 0001578
2009-08-16 14:38ivanStatusresolved => closed

Notes
(0000939)
ivan   
2009-04-20 11:12   
Can you describe exactly what steps are needed to reproduce this. What links are you clicking, what forms are you filling in and what is the exact text of any error message (doesn't matter if it's in french I can look it up).

Thanks!
(0000947)
nicdev   
2009-04-20 13:10   
Hi Ivan,

Sorry i was in a rush so it sounded a bit cryptic. here are the steps:

1. Click on the message title of a message in the Holding queue for a contact that is NOT recognised, i.e the bottom of the shaded list.
2. When you see the incoming mail, click on "assign",
3. next in the "move update" box type the number of an existing incident
4. Then the error is "Error assigning that incident update. This could be because no incident exists with that ID or the incident has been closed."

I have checked that the incident is not closed but even more bizarre is that it now works from my laptop, but not from the engineer that was trying to do it????? Has something changed in the permission structure of 3.45 perhaps??
(0000948)
nicdev   
2009-04-20 13:51   
Hi Ivan,

Found the problem, In the move update script you compare to "strYes" but for the French useres this is "Oui", and this bug is only for French users. I temp changed the i18 file for French to strYes = "Yes" and the problem is solved...

Cheers
(0000954)
ivan   
2009-04-21 22:00   
Thanks! Not only did you file the bug but you fixed it as well! nice one. More of those please ;)

Thats a bit of a clanger, it's a deprecated function call that returns a string instead of a bool which is a bit silly, and because of that 'Yes' has accidentally been internationalised, probably in a search and replace operation.

The fix has been committed as trunk r5343, thanks again!
(0001578)
ivan   
2009-08-16 14:38   
Released in 3.50rc1