SiT! Bugs - SiT!
View Issue Details
0000774SiT!inbound emailpublic2009-07-15 10:252009-08-16 14:40
nicdev 
kieran 
normalmajoralways
closedfixed 
3.45 
3.503.50 
0000774: Attachments with accented characters like "é" in the filename do not get imported
We had some emails imported into the tracker, with accented characters in the filename (filename = "photo étiquette 1.jpg"), and the following happens:

The file "looks like" it gets imported into the case (tested with existing case!), but the filename appears as "=?iso-8859-1?Q?photo_=E9tiquette_1=2Ejpg?=", and when you click on this link, you get a "404 file not found"..

When i go into the attachements/updates folder, the file referenced in hte link is not there which means the import failed although the link was made in the links table (but that seems normal as it is 2 different steps in the script).

Any ideas on if you can reproduce this??

Thanks
No tags attached.
parent of 0001005closed paulh Creating an incident from the holding queue does not move the attachment 
related to 0001275resolved paulh non-ascii characters in inbound email attachment filenames are corrupted 
Issue History
2009-07-15 10:25nicdevNew Issue
2009-07-15 12:32kieranStatusnew => assigned
2009-07-15 12:32kieranAssigned To => kieran
2009-07-15 13:44kieranNote Added: 0001314
2009-07-15 13:44kieranStatusassigned => confirmed
2009-07-15 13:56kieranNote Added: 0001315
2009-07-16 23:08kieranNote Added: 0001335
2009-07-16 23:08kieranStatusconfirmed => resolved
2009-07-16 23:08kieranResolutionopen => fixed
2009-07-16 23:08kieranFixed in Version => Current SVN
2009-08-15 21:31ivanTarget Version => 3.50
2009-08-16 13:15ivanFixed in VersionCurrent SVN => 3.50
2009-08-16 14:40ivanNote Added: 0001721
2009-08-16 14:40ivanStatusresolved => closed
2009-11-06 12:52nicdevRelationship addedparent of 0001005
2010-06-17 12:43ivanRelationship addedrelated to 0001275

Notes
(0001314)
kieran   
2009-07-15 13:44   
Confirmed, sorta. I get the bodged filename but it saves to disk and loads fine. If I solved the filename problem it should hopefully fix both.
(0001315)
kieran   
2009-07-15 13:56   
This is a bug with PHP in Windows that won't be fixed until PHP6, we're going to workaround it by not writing the filename to disk, we don't need to anyway.
(0001335)
kieran   
2009-07-16 23:08   
This has been fixed in trunk svn r5518, please test with both old and new incidents if you can.
(0001721)
ivan   
2009-08-16 14:40   
Released in 3.50rc1