SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000093SiT!schedulerpublic2008-07-13 16:392008-11-21 17:26
Reporterpaulh 
Assigned Toivan 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version 
Target Version3.40Fixed in Version3.40 
Summary0000093: Scheduler allows multiple jobs of the same type to run
DescriptionIts possible that the scheduler can allow the same job to run multiple times.

Say you check every 1 minute for jobs and have a job which could take more than a minute to run it will be picked up twice as the lastran field hasn't been updated yet.

Additional InformationPerhaps we should have a laststart field as well we check? Keeping lastran for the end of the job?
TagsNo tags attached.
Attached Files

- Relationships
child of 0000081closedpaulh Billing reports 

-  Notes
User avatar (0000020)
ivan (administrator)
2008-07-14 13:50

Yeah I agree, we should add a field for laststarted
User avatar (0000103)
ivan (administrator)
2008-10-07 07:48

PaulH thinks this is done now, need to check it.
User avatar (0000139)
ivan (administrator)
2008-10-23 23:43

In my testing today this never happened, but I need to check some more.
User avatar (0000147)
ivan (administrator)
2008-10-29 15:32

I'm happy that this is fixed in 3.40 trunk svn 4097
Please reopen if symptoms occur.

- Issue History
Date Modified Username Field Change
2008-07-13 16:39 paulh New Issue
2008-07-14 13:50 ivan Note Added: 0000020
2008-07-14 13:50 ivan Status new => confirmed
2008-07-14 13:51 ivan Target Version => 3.40
2008-07-14 13:55 ivan Relationship added child of 0000081
2008-07-19 12:31 paulh Status confirmed => assigned
2008-07-19 12:31 paulh Assigned To => paulh
2008-10-07 07:48 ivan Note Added: 0000103
2008-10-07 07:48 ivan Assigned To paulh => ivan
2008-10-07 07:48 ivan Status assigned => feedback
2008-10-23 23:43 ivan Note Added: 0000139
2008-10-29 15:32 ivan Note Added: 0000147
2008-10-29 15:32 ivan Status feedback => resolved
2008-10-29 15:32 ivan Resolution open => unable to reproduce
2008-10-29 15:32 ivan Fixed in Version => 3.40
2008-11-21 17:26 kieran Status resolved => closed


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker