SiT! Bugs

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000983SiT!triggerspublic2009-10-15 20:002010-01-23 19:03
Reporternbl 
Assigned Tonicdev 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version3.45 
Target Version3.51Fixed in Version3.51 
Summary0000983: Trigger Not working for New Held Email
DescriptionWhen creating a trigger to email a user when there is New Held Email in holding queue, it is not working as expected.
Steps that I did
1) Click Control Panel->Templates.
2) Click Triggers, select the user that you want from the drop down list. Then scroll down to look for New Held Email and click Add Action.
3) From the drop down list, click Email. Then click Save.
4) Send a test email to the email address designated to be pick up by SiT.
5) Wait for few minutes, then click Support->Holding Queue, noticed my 1st test email is flooding the screen every minute. If you send a 2nd test email, this 2nd test email will not appear in holding queue, only the 1st email keep looping.
6) Observe that designated user is not receiving email when 5) happened.
Additional InformationThis happened to version 3.50rc3 as well.
TagsNo tags attached.
Attached Filesjpg file icon trigger-keep-looping.jpg [^] (27,410 bytes) 2009-10-16 01:36


txt file icon sit-debug-log.txt [^] (82,357 bytes) 2009-10-16 09:45 [Show Content]
jpg file icon trigger-rules-simple.jpg [^] (28,029 bytes) 2009-10-16 15:45

- Relationships
child of 0000990closedpaulh When creating a new email action the template dropdown is blank 

-  Notes
User avatar (0002099)
nicdev (developer)
2009-10-15 20:38

Hi

1. Which platform and which versions of PHP/MySQL?
2. Can you turn on debug and then check your log for errors?
3. Can you check the php error log as well for errors?

I did these same steps this morning and did not have the same issue.

Thanks
User avatar (0002100)
nicdev (developer)
2009-10-15 20:38

Can you respond to the questions for further information?
(0002104)
nbl (reporter)
2009-10-16 01:39

1. Which platform and which versions of PHP/MySQL?
Ans: CentOS 5.3, PHP 5.1.6 (cli), mysql-5.0.45-7.el5

2. Can you turn on debug and then check your log for errors?
3. Can you check the php error log as well for errors?

Ans: As for 2 & 3, can let me a link where I can follow the steps to gather troubleshooting logs?

Also I just attached a screen shot showing this problem.
User avatar (0002105)
nicdev (developer)
2009-10-16 08:19

In the wiki...

http://sitracker.org/wiki/Debug_Logging [^]
(0002106)
nbl (reporter)
2009-10-16 09:50

Thanks. I've follow the Debug_Logging, simulate and capture the log and uploaded here.
User avatar (0002107)
nicdev (developer)
2009-10-16 15:12

Hi nbl,

It seems that the mail is not deleted when it is first retrieved and then gets re-imported the next time the auto.php runs.

Can you please check your trigger rules and even remove any ones that you created yourself, and redo the test.

The mail should be deleted after the import or (if you have it set up) moved to the "archive folder"
User avatar (0002108)
nicdev (developer)
2009-10-16 15:13

Please check my notes.
(0002109)
nbl (reporter)
2009-10-16 15:45

Hi Nicdev,

If I don't create this trigger for New Held Email, Yes email will be deleted after first retrieve. But once created this trigger, it will appeared like what you saw in my looping screen shot.

My trigger rule is very simple. See another screenshot that I'm going to upload.
(0002111)
nbl (reporter)
2009-10-22 01:02

Hi Nicdev,

You managed to replicate the problem?
User avatar (0002112)
nicdev (developer)
2009-10-22 07:24

Sorry we have all been a bit overloaded it seems. I do not have a running version of Centos, and i could not replicate it yet on windows or on Kubuntu. I will give it another shot before the weekend;

thanks
User avatar (0002114)
nicdev (developer)
2009-10-22 15:05

Ok finally managed to reproduce this.

It is related to bug 990 where the template dropdown is blank. If you ckick "save" without selecting the template you create an action with a blank template in the database.

When you gather the email from the mailbox the script will fail and the email does not get deleted, which re'-imports it next time around. We are working on Bug 990 to try and fix it, but in the mean time if you can (and know how to" you can edit the action entry in the table "triggers" and add the template name.

If you are not confident with editing the database, we will post a fix as soon as possible.
User avatar (0002117)
nicdev (developer)
2009-10-23 08:48

Hi nbl,

This is not a bug as such.

To create a new email action this way you need to first create a new template for yourself, and then you can select it from the dropdown list.

The problem is (according to your screenshot) you created a new action but did not select a template (the dropdown list is empty because you did not create a "user" template). In this case when you click save it creates a new action but with no template specified, and this breaks the script that calls the trigger action, which caused the email not to be deleted, and constantly re-imported.

So i suggest, if you want users to be able to activate this template themselves, then you need to create a template yourself (with a unique name) and then when you create the new email action you will have it in your list to select.

If this is a systel action please click:

Control panel -> Sytem actions to acces the sytem actions. Go and create a new action and select email from the type; Now you will have all the system templates to use. But note only users with admin may change these.

See bug 990 for a complete explination.
User avatar (0002326)
ivan (administrator)
2010-01-23 19:03

Fix released in 3.51 which is now available

- Issue History
Date Modified Username Field Change
2009-10-15 20:00 nbl New Issue
2009-10-15 20:35 nicdev Status new => assigned
2009-10-15 20:35 nicdev Assigned To => nicdev
2009-10-15 20:38 nicdev Note Added: 0002099
2009-10-15 20:38 nicdev Note Added: 0002100
2009-10-15 20:38 nicdev Status assigned => feedback
2009-10-16 01:36 nbl File Added: trigger-keep-looping.jpg
2009-10-16 01:39 nbl Note Added: 0002104
2009-10-16 08:19 nicdev Note Added: 0002105
2009-10-16 09:45 nbl File Added: sit-debug-log.txt
2009-10-16 09:50 nbl Note Added: 0002106
2009-10-16 15:02 nicdev Status feedback => assigned
2009-10-16 15:02 nicdev Assigned To nicdev => ivan
2009-10-16 15:02 nicdev Assigned To ivan => nicdev
2009-10-16 15:12 nicdev Note Added: 0002107
2009-10-16 15:13 nicdev Note Added: 0002108
2009-10-16 15:13 nicdev Status assigned => feedback
2009-10-16 15:45 nbl Note Added: 0002109
2009-10-16 15:46 nbl File Added: trigger-rules-simple.jpg
2009-10-22 01:02 nbl Note Added: 0002111
2009-10-22 07:24 nicdev Note Added: 0002112
2009-10-22 15:00 nicdev Relationship added child of 0000990
2009-10-22 15:05 nicdev Note Added: 0002114
2009-10-23 08:40 nicdev Status feedback => confirmed
2009-10-23 08:48 nicdev Note Added: 0002117
2009-10-23 08:48 nicdev Status confirmed => resolved
2009-10-23 08:48 nicdev Resolution open => no change required
2009-10-23 14:12 ivan Target Version => 3.50p1
2010-01-23 19:03 ivan Fixed in Version => 3.51
2010-01-23 19:03 ivan Note Added: 0002326
2010-01-23 19:03 ivan Status resolved => closed


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker